Activating FairShare™ on your Enforcer
The FairShare feature is part of the Enforcer Config Scripts. it will need to be manually updated for the FairShare™ to work.
Please see the RouterOS scripts below for the FairShareTM component:
FairShare™ is fairly simple. It consists of two components.
1. Firewall Rules to tag the Inbound and Outbound Packets
/ip firewall mangle
add action=mark-packet chain=output comment=”Lucidview Enforcer” dst-address=
35.189.74.99 new-packet-mark=lucidview passthrough=no
add action=mark-packet chain=input comment=”Lucidview Enforcer”
new-packet-mark=lucidview passthrough=no src-address=35.189.74.99
add action=mark-packet chain=forward in-interface=ether1 new-packet-mark=in
passthrough=no
add action=mark-packet chain=forward new-packet-mark=out out-interface=ether1
passthrough=no
Please update the above with the correct interface for your Internet. For example, your ether1 might be replaced by the PPPoE interface.
2. Shaping Queues
/queue type
add kind=pcq name=pcq_in pcq-classifier=dst-address pcq-dst-address6-mask=64
pcq-limit=1000KiB pcq-src-address6-mask=64 pcq-total-limit=20000KiB
add kind=pcq name=pcq_out pcq-classifier=src-address pcq-dst-address6-mask=64
pcq-limit=1000KiB pcq-src-address6-mask=64 pcq-total-limit=20000KiB
add kind=pfifo name=normal pfifo-limit=10000
/queue tree
add comment=lvcloud disabled=no max-limit=100M name=In packet-mark=in
parent=global priority=1 queue=normal
add comment=lvcloud disabled=no max-limit=100M name=Out packet-mark=out
parent=global queue=normal
add disabled=no name=Download packet-mark=in parent=In priority=1 queue=
pcq_in
add disabled=no name=Upload packet-mark=out parent=Out queue=pcq_out
add disabled=no name=Lucidview packet-mark=lucidview parent=In priority=1
queue=pcq_in
You will notice new PCQ shaping queue types defined as well as input and output queues limited to 100 Mbps for both in and out. This you can adjust to your network speed. Typically it is recommended to make the max-limit slightly less than the line speed (Usually about 10% less than the total) so packets are queued on the MikroTik instead of being indiscriminately dropped by your ISP.
.