Routing Marks and Packet Marks for Traffic Flow
# Input and output rules for VPN communication between Mikrotik and LucidView cloud
/ip firewall mangle
add action=mark-connection chain=input comment=lvcloud_<LUI> in-interface=lvcloud new-connection-mark=lvcloud_<LUI> passthrough=yes
add action=mark-routing chain=output comment=lvcloud_<LUI> connection-mark=lvcloud_<LUI> new-routing-mark=lvcloud_<LUI> passthrough=yes
# DNS Intercept for each profile based on src-address-list
add action=mark-packet chain=prerouting dst-port=53 new-packet-mark=lvcloud_<LUI> passthrough=yes protocol=tcp src-address-list=lvcloud_<LUI>
add action=mark-packet chain=prerouting dst-port=53 new-packet-mark=lvcloud_<LUI> passthrough=yes protocol=udp src-address-list=lvcloud_<LUI>
add action=mark-routing chain=prerouting new-routing-mark=lvcloud_<LUI> passthrough=yes packet-mark=lvcloud_<LUI> src-address-list=lvcloud_<LUI>